Spelling autocorrect menu option resetting

In this latest release of MacOS Panda (2952), the spelling autocorrect option is not “sticky” - it resets on opening a new note and when restarting Panda.

Steps to reproduce

  • Open a note
  • Go to Edit > Spelling and Grammar and ensure “Correct Spelling Automatically” is selected
  • Go to Edit > Spelling and Grammar and select the option for “Check Spelling While Typing”

At this point, autocorrect of spelling mistakes works as expected.

However, either restart Panda or open another note and that option (Check Spelling While Typing) is no longer selected - leading to spelling autocorrect no longer working. Until that option is once again manually re-selected.

Expected Behavior

  • Spelling autocorrect options should be permanent until manually changed by the user

I realize this bug may be moot with regard to the editor’s incorporation into Bear, but for anyone considering using Panda post Bear 2.0, it would be nice if this could be fixed.

Hello and sorry I missed this thread.

Unfortunately I can reproduce the issue here (macOS 12.4), any chance you have another macOS release?

Hi @trix180 - yes, macOS Monterey, 12.4. Mac Studio (2022), Apple M1 Max chip. Panda Version 1.0 (2952)

Easy to reproduce:

  • Open a new Panda note.
  • Set spelling options to first image below (in other words, enable Check Spelling While Typing).
  • Close and re-open same Panda note (or open any other or a new Panda note) and you get the 2nd image below: Check Spelling While Typing is now unchecked.

Neither rebooting Mac nor restarting Panda make a difference.

Note that I do not see this issue with Bear on the same machine. It is specific to Panda. Perhaps related to M1 Max?

Thanks again.

I’m not aware of similar problems connected to Apple Silicon compiled apps but I have found something on Apple’s Developer Forums. Some macOS 12 users had the same problem and found a solution by restarting their mac in safe mode or manually changing the relative defaults key.

I suggest trying the above only if the same problem happens in other apps.

Hi @trix180 - i just tried on a few other macs nearby (regular M1s) and see the exact same issue. So this definitely looks like a Panda issue. The links you sent are not the issue I’m having as this works just fine in all apps (Safari, Bear, TextEdit, etc.) EXCEPT Panda. Again, open a note, enable Check Spelling While Typing, close and reopen note, and you’ll see that option is no longer checked.

I should also note that this issue did not exist in the previous Panda release.

Thanks.

Ok I got it. Somehow I replaced “close” with “quit” in my head. It’s surprising quit and close produce different outcomes in this case but luckily We can reproduce and error and hopefully fix the error now.

Thanks for reporting this problem.

1 Like