Unintentional Styling?

Testing version:
Version 1.0 (2595)

What were you doing:
Was typing a normal sentence and entered down to a new line where I intended on adding a bulleted list.

What feature did you use:
Was trying to add a bulleted list on a line that was directly under a sentence I had just written.

What happened:
Instead of getting a bullet, it turned the line above into what looks like an H2 header, and the dash I was using to create the bullet turned into a divider line or separator.

What did you expect to happen:
What I expected to happen was for the line above to be left alone and the dash + space I typed to be turned into a bullet, not a divider/separator.

Notes:
As for the line that gets turned into a header, I wrote the exact sentence above it and first tried H1 which was larger, then tried H2 and that was the exact size (as far as I can tell) as the line that gets changed to an H2 header automatically when typing a dash and a space on the very next line.

Also, I tried putting the cursor on the line that gets changed to an H2 header and there’s no button or indicator that shows up in the gutter allowing you to change it.

Steps to Reproduce:

  1. Write something on a line (could be a word or sentence)
  2. Enter down to the very next line
  3. Type a dash
  4. Type a space

You can undo and redo by:

  1. CMD + z (The sentence above should change back to normal text & there should be a dash left on the next line)
  2. Type a space (to redo the unintended styling)

So, I’m writing this in as a bug report as I don’t think this should act this way. Although, I could totally be wrong. Is Panda doing this intentionally? If so, I apologize for the report.